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Chapter 1 – Introduction 
Introduction 
Warrants 10 is a simple, easy-to-use tool to analyze traffic signal and All Way Stop Control 
(AWSC) warrants using the methods prescribed in the 2003 and 2009 Manual on Uniform 
Traffic Control Devices (MUTCD) and includes amendments for the 2012 California MUTCD.  
Trafficware Warrants 10 is unique in that multiple intersections can be stored in a single 
file. This allows the analyst to quickly review the warrant status for the intersections in their 
study area/jurisdiction.  

Warrants 10 also interacts with Synchro. If a user has a model created in Synchro, 
intersection name/node data can be transferred to Warrants. In return, the traffic volume 
data from Warrants can be imported into Synchro (user defined interval). 

According to the MUTCD, the investigation of the need for a traffic control signal shall 
include an analysis of the applicable factors contained in nine traffic signal warrants (eight 
if using the 2003 MUTCD methods) and other factors related to existing operation and safety 
at the study location. 

The satisfaction of a traffic signal warrant or warrants shall not in itself require the 
installation of a traffic control signal. Warrants 10 faithfully implements all nine MUTCD 
warrants that include: 

• Warrant 1, Eight-Hour Vehicular Volume. 
• Warrant 2, Four-Hour Vehicular Volume. 
• Warrant 3, Peak Hour. 
• Warrant 4, Pedestrian Volume. 
• Warrant 5, School Crossing. 
• Warrant 6, Coordinated Signal System. 
• Warrant 7, Crash Experience. 
• Warrant 8, Roadway Network. 
• Warrant 9, Intersections Near a Grade Crossings (new in the 2009 MUTCD) 

In Addition, Warrants includes the MUTCD warrant for an AWSC control and the California 
warrant for bicycles. 



1-2 

Warrants 10 Installation 
Warrants 10 is included in the Synchro Studio installation file. A unique License Key is 
necessary to use Warrants 10. 

If you have downloaded Synchro Studio with Warrants 10 from the Internet, run setup.exe 
from your download directory. 

The Installation Wizard will guide you through the installation process (after you 
download the setup file). It is recommended that you close all other applications before 
starting installation. Press [Next] to begin. 
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1. Read the license agreement carefully. 

 
Select the [I Agree] button to accept the terms of the license agreement and proceed 
with the installation. You must accept the license agreement to install Synchro Studio 
10, Warrants 10, and TripGen 10. 
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2. The Installation Wizard saves all files to the default directory C:\Program Files 
(x86)\Trafficware. 

 
Synchro Studio 10, Warrants 10, and TripGen 10 are now ready to install.  Select the 
[Install] button to install in the selected directory. 
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3. When the installation is complete, you will be promoted to reboot your computer. It is 
recommended that you do this immediately, but you may reboot manually later. Select 
the [Finish] button to exit the Installation Wizard. 
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To Activate Warrants 

 
When you activate Warrants, activate under the user’s profile on the PC. Log on to the 
laptop/PC as the User Profile of the individual that will be using Synchro Studio 10. 

1. Select the Start Menu, then choose Programs→Trafficware→Warrants 10 or double 
click on the shortcut from your desktop. 

2. Read the license agreement carefully. 

 
Check the ‘I Accept the Trafficwre® License Agreement and Microsoft® Bing™ Maps 
Terms of Use’ box to proceed.  

Select [Activate] to proceed with the activation. Press [Reader] if you want to use the 
read only version. The read only version will allow you to try out the features by viewing 
the sample files. The sample files are located in the directory where you have installed 
Synchro Studio 10. You will not be able to create your own network with the demo 
mode. 
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3. The first time using Warrants, you will be asked to activate your software. Enter the 
requested information on the Application Activation dialog shown here. 

 

The information entered in the Application Activation dialog is used to setup 
the profile for online support with Trafficware. Be sure to enter the information 
for the individual that will be using the software. 

 
The License Key is provided by Trafficware and will be shown on your license certificate 
and will be emailed to you. The License Key is in the format (Serial Number / Company 
Name - Product Key).  

 
To ensure accurate entry into the Application Activation dialog, copy the entire 
string from your email message and paste into the License Key box. 

The entries with the asterisk “*” are required to activate Warrants.  

After entering the necessary information, select [OK].  
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4. The next dialog gives you two options to activate and an option to activate later.  

 
‘Activate using the Internet’ is the preferred method for activating your software. 
Choose this option and select [OK] to automatically and quickly activate your software.  

If you do not have an internet connection, use the ‘Activate by Phone’ option and press 
[OK]. Follow the instructions on the Phone Activation dialog. Before calling, make sure 
invoice has been paid and have your license key available. Trafficware staff will ask for 
the Machine Key listed in the Phone Activation dialog. With this information, an 
Activation Code will be provided. 

To View Sample Files 
Warrants comes with sample files so that you can see how intersections are modeled in 
Synchro. To view the sample files: 

1. From Warrants, choose the File→Open command. 

2. Navigate to the C:/Program Files(x86)/Trafficware/Version 10/Sample Files folder.  

3. Select “DemoWarrants.swn” from the list.  

Getting Help 
Trafficware offers a variety of options for you to learn Warrants as presented in this 
section. 
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Warrants Digital User Guide 
The Digital User Guide (online manual) is designed to open in the Adobe® Acrobat® 
Reader. If you do not have the Acrobat Reader, you can download the application from: 

http://www.adobe.com/products/acrobat/readstep2.html.  

To load the Warrants Digital User Guide file within Warrants, press [F1]. The Help file will 
appear. 

In the Acrobat window, press on the Bookmarks tab to show the contents of the Help. You 
can click the plus/minus icon to the left to expand or collapse the outline. Select a topic 
bookmark to jump to the section of the Synchro Studio Digital User Guide. 

Use the Acrobat Search feature to search for words in the Help system and locate topics 
containing those words. Type the word in the text box and click Search. The results list 
shows the titles of all topics in which the search word appears, listed in the order that they 
appear within the document.  

Contacting Trafficware 
Before contacting Trafficware, you can find answers to many of your questions in the on-
line Help file. Additional sources of information are also available on the Trafficware web 
site.  

Online Support 
Warrants 10 support is available by going to http://online.trafficware.com/support/ and 
logging into the support system. You can also get to the support center by using the 
command Help→ Support.  Submit your question and the necessary Warrants (*.swn) file 
to the support ticket. Trafficware will be happy to answer your technical question, usually 
within a 24-hour period.   

Technical Articles 
Read articles regarding Trafficware products on our Resources Page of our website 
(http://www.trafficware.com/resources.html).   

Discussion Web 
Access our Discussion Web for Trafficware Software. 

http://www.adobe.com/products/acrobat/readstep2.html
http://online.trafficware.com/support/
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Build History 
Check out Trafficware Software's History on our Build History Page. 

Use the command Help→Check for New Version. A dialog box appears that will indicate if 
your build is up to date. The version check is made over the internet with HTTP 
protocol.  This communication should pass through most firewalls.  

Training Classes 
Check out classes being offered by Trafficware University: 
http://www.trafficwareuniversity.com/. 

Providing Documentation Feedback 
Trafficware strives to produce the highest quality online help and printed documentation. 
We want to help you learn about our products and get your work done quickly. We welcome 
your feedback. Please send your comments to training@trafficware.com. 

Keeping Up to Date 
To keep this information up to date, Trafficware might issue new printings of this manual. 
New printings reflect minor changes and technical corrections. You can keep this 
information up to date by visiting and installing the latest revision of the Trafficware 
software; the Warrants User Guide is replicated in the Help Menu of the program. 

System Requirements 
Warrants has the following requirements for the computer. 

• CPU:    Pentium 4 or higher 

•  Operating System:    Windows 7, Windows 8, or Windows 10 

•  Mouse:     Required 

•  Memory:    4GB RAM minimum 

•  Hard Disk:    50M Free Space 

•  Monitor:  Accelerated graphics adapter recommended 

mailto:training@trafficware.com
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Chapter 2 – Getting Started 
This section provides an overview of Warrants 10, introducing you to some of the main 
features. To launch Warrants 10, Select the Start Menu, then choose 
Programs→Trafficware→Warrants 10 or double-click on the warrants shortcut from your 
desktop. 

Getting Started 
1. Select the File→New command to start with a new file. 

  

2. On the toolbar, select the Federal 2003 or 2009 option 
for the Federal MUTCD warrants or the California 2012 
for the California MUTCD warrants.  

 

3. To add an intersection, click the “New Intersection” toolbar button , and enter 
the applicable information in the popup window. If you are a Synchro user, the ID 
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should match the Node Number used in any Synchro network. Add additional 
intersections as desired. 

 
4. Select an intersection from the left Intersection List pane and select the ‘Summary’ 

tab in the right pane. The summary tab has sub-tabs for ‘Status’, ‘Site Information’, 
‘Vehicle Volumes’, ‘Pedestrian Volumes’, ‘Gaps’, and ‘Delays’. Choose the ‘Site 
Information’ sub-tab. 
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5. From the ‘Site Information’ sub tab, enter the appropriate data. In the Approach 
Information section, make sure to check the approaches to include in the analysis 
and define the Major route directions. 
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6. From the ‘Summary’ tab, select the ‘Vehicle Volumes’ sub-tab and enter the 
appropriate Normal Weekday volumes and/or Weekend Volumes.  

  
7. Continue by entering available data for ‘Pedestrian Volumes’, ‘Gaps’ and ‘Delays’. Not 

all data in needed to analyze warrants. However, some warrants will not be 
performed if data is not available.  

8. Additional warrant specific data can be entered on the ‘Warrant 1’ through ‘Warrant 
9’ tabs. The tabs will also show the status of the given warrant. 
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9. Refer back to the ‘Status’ tab for the current warrant analysis status. Choosing a new 
intersection from the left pane will update the Status view for the selected 
intersection. 
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Warrants Layout 
Figure 1 illustrates the layout of Warrants.  

 

Figure 1 Warrants 10 Layout  
In Figure 1, 

A is the title bar for the current file. It will illustrate the name of the active file.  

B shows the menu commands. Refer to the next section for a complete summary of the menu 
commands.  

The toolbar is noted as C. Hold your mouse curser over a button for pop-up text indicating 
the button feature. In the toolbar, you can select to analyze Federal 2003, Federal 2009 or 
California MUTCD warrants. 

D is the left-side pane of the Warrants window, containing the intersection list. For details, 
refer to page 3-1. 
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E is the right-side pane that includes the summary view or data entry screens. The data 
shown on the right-side pane is dependent on the tab selected (F in the figure). Refer to the 
remainder of this User Guide for details on each data entry tab. 

Summary of Menu Commands 
Warrants 10 has a variety of commands that can be accessed with button clicks, left 
mouse-click commands or menu commands. This section will summarize the available 
commands (listed in order shown in the menu commands). 

Table 1 File Commands 

Menu Command Action Keystrokes 
File→New Start a new file [Ctrl]+[N] 
File→Open Open an existing file [Ctrl]+[O] 
File→Save Save the file you are working on [Ctrl]+[S] 
File→Save-As Save the current file with a new name - 
File→Print Creates a report of the active tab [Ctrl]+[S] 
File→Print-All-
Reports 

Creates a report of all intersections, all reports [Ctrl]+[R] 

File→'list of files' Shows the list of the last four files that were 
opened 

- 

File→Exit Exits the program - 
  

Table 2 Edit Commands 

Menu Command Action Keystrokes 

Edit→Undo Use to undo multiple changes [Ctrl]+[Z] 
Edit→Cut Cut the current data and send to the clipboard [Ctrl]+[X] 
Edit→Copy Copy the selected data to the clipboard [Ctrl]+[C] 
Edit→Paste   Paste the data in the clipboard to Warrants [Ctrl]+[P] 

 



2-8 

Table 3 Transfer Commands 

Menu Command Action Keystrokes 

Transfer→Import→UTDF→  
Layout… 

Imports a UTDF Database Access 
layout file (layout.csv) 

- 

Transfer→Import→UTDF→  
Volumes… 

Imports a UTDF Database Access 
volume file (volume.csv) 

- 

Transfer→Import→UTDF→  
Combined File… 

Imports a UTDF Database Access 
combinded file (filename.csv) 

- 

Transfer→Import→Vol file(s)… Imports multiple UTDF TMC.vol 
files (TMC#.vol) 

- 

Transfer→Export→UTDF→  
Combined File… 

Exports a UTDF Database Access 
combinded file (filename.csv) 

- 

 

Table 4 View Commands 

Menu Command Action Keystrokes 

View→Multiple-Intersection 
Reports 

Create reports for multiple 
intersections 

- 

View→Toolbar View/hide the toolbar - 
View→Status Bar View/hide the Status bar - 

  

Table 5 Help Commands 

Menu Command Action Keystrokes 

Help→Contents Open the Help file [Shift]+[F1] 

Help→About Warrants Shows the current version, build 
and copyright 

- 

Help→License Key Shows your Product Key - 
Help→Support Opens the Trafficware support site - 
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Support for Federal and California Warrants 
Warrants 10 includes support for the 2003 Federal, 2009 Federal and 2012 California 
Manual on Uniform Traffic Control Devices (MUTCD). On the toolbar, select the dropdown 
for the analysis type.  

The Federal 2009 Warrants include 9 signal warrants, listed on page 1-1. Warrant 9 was 
newly added to the 2009 MUTDC for intersections near rail crossings. In addition, warrant 
4 was updated for the 2009 warrants.   

In general, the California Warrants mimic the Federal warrants with a few exceptions. The 
most significant difference between the methods is to how vehicular volumes are compared. 
That is, how to define the minor street volumes and the major street volumes. Vehicular 
Volumes are used by Warrant 1, 2, 3, 7 and 8. 

Refer to the following information. 

 
For the California method, method 1C is the same as 1F. However, 2F (checking mainstreet 
lefts) differs as noted above. 

Federal Warrant
Traditional Method

6

Check Major Street Lefts

California Warrant
Traditional Method (same as federal warrant)

Check Major Street Lefts

1F

2F

1C

2C

12 11 10

6
5
4

1
2 7 8 9

3

Major Street Volume 1+2+3+4+5+6 User may exclude any 
movement(s)

Minor Street Volume Max of 7+8+9
or 10+11+12

User may exclude any 
movement(s)

Major Street Volume If 4>1, 1+2+3
If 1>4, 4+5+6

User may exclude any 
movement(s)

Minor Street Volume Max 4 or 1 User may exclude any 
movement(s)

Major Street Volume 1+2+3+4+5+6 User may exclude any 
movement(s)

Minor Street Volume Max of 7+8+9
or 10+11+12

User may exclude any 
movement(s)

Major Street Volume If 4>1, 1+2+3+5+6
If 1>4, 2+3+4+5+6

User may exclude any 
movement(s)

Minor Street Volume If 4>1, 4+Max of 7+8+9 or 10+11+12
If 1>4, 1+Max of 7+8+9 or 10+11+12

User may exclude any 
movement(s)

Major 
Street
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The California MUTCD adds a bicycle warrant that is not included in the Federal MUTCD. 
This warrant is only available when the California Option is selected. It looks at vehicle 
volumes, bicycle volumes, collisions and geometry and is detailed on page 5-41. 
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Chapter 3 – Intersection List Pane 
The Intersection List pane is always in view on the left side of Warrants 10.  

 

Figure 2 Intersection List  
Use the Intersection List to activate an intersection for analysis. To enter data for an 
intersection, select the ID/Intersection Name to activate. Then, choose the appropriate tab 
at the lower portion of the right pane. To edit the information seen in the Intersection List, 
use the New, Edit, and Delete toolbar buttons (see page 3-2 for more details). 

ID Number 
All intersections analyzed are assigned a unique ID Number. This is used to identify 
intersections in the reports and for transferring data to and from Synchro’s Universal Traffic 
Data Format (UTDF). Therefore, the Warrants ID number should match any Node (ID) 
number used in Synchro.  

Synchro accepts node numbers up to 9999, so it is recommended that the ID used in 
Warrants not exceed this value. 

Intersection 
The Intersection column can be used to provide a longer description of the intersection 
such as "1st and Main", whereas ID Number identifies the same intersection by number. If 
the data is imported from a Synchro network, the east/west street will be listed first and the 
north/south street will be listed second. For details on importing layout data from Synchro, 
refer to page 7-1. 
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Type 
The Type column specifies whether the intersection is currently signalized, unsignalized or 
roundabout. 

Adding a New Intersection 
To add a new intersection to the study, click the “New Intersection” toolbar button  
and enter the applicable information in the popup window.  

Editing an Existing Intersection 
To edit an existing intersection, select an intersection in the list and click the “Edit 
Intersection” toolbar button . 

Deleting an Intersection 
To delete the selected intersection, click the “Delete Intersection” toolbar button . A 
prompt will ask for confirmation. 
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Chapter 4 – Summary Tab 
The summary tab is the view the user will see when the software is opened. Select an 
intersection from the Intersection List, then select the Summary tab at the bottom of the 
right-hand pane. The screen will show the current status of the warrant (met, not met or not 
applicable (N/A)).  The status will be for the Federal 2009, Federal 2003 or California 2012 
warrants, as selected by the user. 

This view includes a series of sub-tabs as shown in Figure 3. This chapter discusses the 
settings in the Summary tab. 

Status 

 
Figure 3 Status View 
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The Status view shows the status of the warrants for the selected intersection (the number 
of warrants will depend on the method used). The status will indicate “Met”, “Not Met”, or 
“N/A” if the warrant is not selected for inclusion in the analysis.  

The top of the Status tab will show the active intersection ID and name. For example, “13 - 
Main Street and 1st Street”.  

To see the data for a particular warrant, click on the hyperlink warrant name in the right-
side pane, or choose the appropriate tab at the bottom of the right-side pane. 

The Status view also includes a Notes box. This is a convenient location for the analyst to 
enter notes specific to the project/intersection.  
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Site Information 

 
Figure 4 Summary Tab, Site Information Sub-Tab 

To enter the primary data for your intersection, choose the intersection from the left side 
Intersection List pane and choose the Summary tab. The Summary tab has subtabs for entry 
of Site Information, Vehicle Volumes, Pedestrian Volumes, Gaps and Delays. Not all data is 
required to perform a warrant analysis.  
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Site Information Sub-Tab 
This tab includes site-specific information for the selected intersection.  

Community Size 
This value is used to determine which MUTCD tables and figures are to be used. Lower 
thresholds are required when the intersection is in an isolated community of less than 
10,000 people in Warrant 1, Warrant 2, Warrant 3 and Warrant 7.  

Pedestrian Crossing Speed 
This is the walking speed of pedestrians (ft/sec) used for Warrant 4.  

Crashes Correctable by Signal 
This number is compared to the five crashes required in the Crash Experience warrant, but 
only those crashes susceptible to correction by signal installation should be included as 
described in Warrant 7 (see page 5-26). 

Alternatives Failed to Reduce Crash Frequency 
Adequate trial of alternatives with satisfactory observance and enforcement has failed to 
reduce the crash frequency. Refer to Warrant 7 on page 5-26. 

New Signal will Restrict Flow of Traffic 
Check if the new signal will restrict the flow of traffic. 

Student Crossing Time Interval 
The need for a traffic control signal shall be considered when an engineering study of the 
frequency and adequacy of gaps in the vehicular traffic stream as related to the number and 
size of groups of school children at an established school crossing across the major street 
shows that the number of adequate gaps in the traffic stream during the period when the 
children are using the crossing is less than the number of minutes in the same period (see 
Section 7A.03 of the 2009 MUTCD) and there are a minimum of 20 students during the 
highest crossing hour. 

Total Entering Volume Growth Percentage 
Used for the Roadway Network Warrant. 
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Projected Time Period 
Used for Roadway Network Warrant. 

Include in Analyses 
Check to include the approach in the analysis. At least 2 approaches must be selected to 
begin a warrant analysis.  

Name 
Enter the Name of the roadway approach (i.e., “Main Street”). 

Major 
Check this box to define the Major street direction(s). The remaining are Minor approaches. 

Acceptable Platooning 
Progressive movement in a coordinated signal system sometimes necessitates installing 
traffic control signals at intersections where they would not otherwise be needed in order 
to maintain proper platooning of vehicles. 

Adj. Coord. Signal 
Select this option if there is an existing adjacent coordinated intersection. 

Adj. Intersection Distance 
Distance in feet to adjacent signalized intersection. Entered distance is only analyzed if the 
Adjacent Coordinating Signal box is checked. 

Median Refuge 
Select this option if the approach is a divided street having a median of sufficient width for 
pedestrians to wait. Set this for the direction that pedestrians will walk. For instance, EB 
peds are defined as those that cross the south leg of an intersection. If EB pedestrians have 
a median refuge, set this for the EB column. Refer to Figure 5. 
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Figure 5 Coding Median Refuge 

Speed Limit and 85th Percentile Speed 
This speed is used to determine which MUTCD tables and figures are to be used. Lower 
thresholds are required when the major street speed is above 40 mph (70 km/h) in Warrant 
1, Warrant 2, Warrant 3, Warrant 7 and Warrant 9. 

Include in Analysis 
This setting gives the analyst the option to include/exclude a specific movement from the 
analysis.  

The study should consider the effects of the right-turn vehicles from the minor-street 
approaches. Engineering judgment should be used to determine what, if any, portion of the 
right-turn traffic is subtracted from the minor-street traffic count when evaluating the count 
against the above signal warrants. 

Engineering judgment should also be used in applying various traffic signal warrants to 
cases where approaches consist of one lane plus one left-turn or right-turn lane. The site-
specific traffic characteristics dictate whether an approach should be considered as one lane 
or two lanes. For example, for an approach with one lane for through and right-turning 
traffic plus a left-turn lane, engineering judgment could indicate that it should be considered 

Median refuge sufficient 
to store pedestrians. 

Code Median Refuge for 
EB column

Median refuge sufficient 
to store pedestrians. 

Code Median Refuge for 
WB column

N

North/South Major Street East/West Major Street

Median refuge sufficient 
to store pedestrians. 

Code Median Refuge for 
SB column

Median refuge sufficient 
to store pedestrians. 

Code Median Refuge for 
NB column
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a one-lane approach if the traffic using the left-turn lane is minor. In such a case, the total 
traffic volume approaching the intersection should be applied against the signal warrants 
as a one-lane approach. The approach should be considered two lanes if approximately half 
of the traffic on the approach turns left and the left-turn lane is of sufficient length to 
accommodate all left-turn vehicles. 

Similar engineering judgment and rationale should be applied to a street approach with one 
lane plus a right-turn lane. In this case, the degree of conflict of minor-street right-turn 
traffic with traffic on the major street should be considered. Thus, right-turn traffic should 
not be included in the minor-street volume if the movement enters the major street with 
minimal conflict. The approach should be evaluated as a one-lane approach with only the 
traffic volume in the through/left-turn lane considered. 

Lanes & Sharing 
This setting indicates the number of lanes and sharing for the movement.  

Yearly Growth Pct. 
This is the percent growth rate for Warrant 8. 

Rail Crossing 
Check this box if a rail crossing exists for this movement. This is used for the Federal 2009 
Warrant 9. 

Site Information Tab Needs Summary 

Table 6 lists the Site Information Data requirements. In the table, an ‘R’ indicates that the 
data is required for the warrant. The ‘O’ indicates that the data is optional. A blank indicates 
that the data is not required for the given warrant in the column. Column “A” is for the AWSC 
and column “B” is for the California Bicycle warrant. 
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Table 6 Site Information Data Requirements 

Data Item 
Warrant 

1 2 3 4 5 6 7 8 9 A B 
Community Size R R R       R     R   
Pedestrian Crossing Speed       R               
Crashes Correctable by 
Signal/AWSC             R     O   

Alternatives Failed to Reduce 
Crash Frequency             R         

New Signal will Restrict Flow of 
Traffic       R R R           

Student Crossing Time Interval         R             
Total Entering Volume Growth 
Percentage               R       

Projected Time Period               R       
Include in Analyses (Approach) R R R R R R R R   R R 
Name O O O O O O O O   O O 
Major R R R R R R R R   R R 
Acceptable Platooning           R           
Adj. Coord. Signal       R R R           
Adj. Intersection Distance         R R R         
Median Refuge       O               
Speed Limit R R R       R R  R R R 
85th Percentile Speed O O O       O O  O O O 
Include in Analysis (Movement) R R R         R       
Lanes & Sharing R R R         R       
Yearly Growth Pct.               R       
Rail Crossing                 R     
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Vehicle Volumes 
The Vehicle Volumes sub-tab is shown in Figure 6. Traffic volume data for the normal 
weekday and weekend are entered in this view. 

Figure 6 Summary Tab, Vehicle Volumes Sub-Tab 

Data can be manually entered, imported (see page 7-1) or copied and pasted into the cells. 
To copy and paste, use the Edit menu commands or [Ctrl]+[C] to copy and [Ctrl]+[V] to paste. 
The time period can range from 0:00 to 24:00. 
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Normal Volumes 
These are the normal, weekday 15-minute traffic volumes. Up to 24 hours of data can be 
entered for an intersection.  

Weekend Volumes 
These are weekend 15-minute traffic volumes. They may be influenced by entertainment or 
recreation. 

Vehicle Volume Data Needs Summary 
Table 7 lists the Vehicle Volume Data requirements. In the table, an ‘R’ indicates that the 
data is required for the warrant. The ‘O’ indicates that the data is optional. A blank indicates 
that the data is not required for the given warrant in the column. Column “A” is for the AWSC 
and column “B” is for the California Bicycle warrant. 

Table 7 Vehicle Volume Data Requirements 

Data Item 
Warrant 

1 2 3 4 5 6 7 8 9 A B 
Normal Volumes R R R R     R R R R R 
Weekend Volumes O O O O     O O O O O 
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Pedestrian Volumes 
The Pedestrian Volumes sub-tab is shown in Figure 7. Pedestrian volume data for the 
appropriate approaches is entered in the view. The time period can range from 0:00 to 
24:00. 

 
Figure 7 Summary Tab, Pedestrian Volumes Sub-Tab 

Student Pedestrians During Crossing Interval 
Enter the number of students crossing during the defined time period used by Warrant 5 
(refer to page 5-17). 
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Pedestrian Volumes 
These are the normal pedestrian volumes crossing the roadway. Use Figure 8 to determine 
the approach heading to use for entering pedestrian volumes.  

  
Figure 8 Summary Tab, Site Information Sub-Tab 

Pedestrian Volume Data Needs Summary 
Table 8 lists the Pedestrian Volume Data requirements. In the table, an ‘R’ indicates that the 
data is required for the warrant. The ‘O’ indicates that the data is optional. A blank indicates 
that the data is not required for the given warrant in the column. Column “A” is for the AWSC 
and column “B” is for the California Bicycle warrant. 

Table 8 Pedestrian Volume Data Requirements 

Data Item 
Warrant 

1 2 3 4 5 6 7 8 9 A B 
Student Pedestrians During 
Crossing Interval         R             

Pedestrian Volumes       R     O       O 

EB and WB peds 
crossing south leg. 
Code in EB Peds 
column.

NB and SB peds 
crossing east leg. 
Code in NB Peds 
column.

EB and WB peds 
crossing north leg. 
Code in WB Peds 

column.

NB and SB peds 
crossing west leg. 
Code in SB Peds 

column.

N
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Gaps 
The Gap sub-tab is shown in Figure 9. Gap data for the appropriate approach is entered in 
this view.  

 
Figure 9 Summary Tab, Gap Sub-Tab 

Acceptable Gaps During Student Crossing Interval 
Enter the number of gaps acceptable for students crossing by direction. Refer to page 5-17 
for additional details. 
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Gaps 
Gaps in the traffic stream of adequate length to allow pedestrians to cross during the same 
period when the pedestrian volume criterion is satisfied. Where there is a divided street 
having a median of sufficient width for pedestrians to wait, the requirement applies 
separately to each direction of vehicular traffic. If the direction is set to have a Median 
Refuge, then code the gap for both sides of the median. Refer to Figure 10. 

 
Figure 10 Coding Pedestrian Gaps 

Gap Data Needs Summary 
Table 9 lists Gap Data requirements. In the table, an ‘R’ indicates that the data is required 
for the warrant. The ‘O’ indicates that the data is optional. A blank indicates that the data is 
not required for the given warrant in the column. Column “A” is for the AWSC and column 
“B” is for the California Bicycle warrant. 

Table 9 Gap Data Requirements 

Data Item 
Warrant 

1 2 3 4 5 6 7 8 9 A B 
Acceptable Gaps During 
Student Crossing Interval         R             

Gap Data       R               

EB and WB peds 
crossing south leg. 
Code in EB Gaps 
(g1) column.

NB and SB peds 
crossing east leg. 
Code in NB Gaps 
(g1) column.

EB and WB peds 
crossing north leg. 
Code in WB Gaps 

(g1) column.

NB and SB peds 
crossing west leg. 
Code in SB Gaps 

(g1) column.

EB and WB peds 
crossing north leg. 
Code in WB Gaps 

(g2) column.

EB and WB peds 
crossing north leg. 
Code in WB Gaps 
(g1) column.

EB and WB peds 
crossing south leg. 

Code in EB Gaps 
(g1) column.

EB and WB peds 
crossing south leg. 
Code in EB Gaps 
(g2) column.

No Median Refuge Median Refuge on N/S Street for E/W Pedestrians
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Delays 
The Delays sub-tab is shown in Figure 11. 

 
Figure 11 Summary Tab, Delays Sub-Tab 

Delay Data 
The average stopped delay for each approach is coded in minutes per vehicle. The 
appropriate volumes will be used to calculate the total stopped delay in vehicle hours.  
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Delay Data Needs Summary 
Table 10 lists the Delay Data requirements. In the table, an ‘R’ indicates that the data is 
required for the warrant. The ‘O’ indicates that the data is optional. A blank indicates that 
the data is not required for the given warrant in the column. Column “A” is for the AWSC and 
column “B” is for the California Bicycle warrant. 

Table 10 Delay Data Requirements 

Data Item 
Warrant 

1 2 3 4 5 6 7 8 9 A B 
Delay Data     O         O   O   
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Bicycles 
The Bicycles sub-tab is shown in Figure 12. 

 
Figure 12 Summary Tab, Bicycles Sub-Tab 

Bicycle Data 
These are the bicycle volumes crossing the roadway.   
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Bicycle Data Needs Summary 
Table 10 lists the Bicycle Data requirements. In the table, an ‘R’ indicates that the data is 
required for the warrant. The ‘O’ indicates that the data is optional. A blank indicates that 
the data is not required for the given warrant in the column. Column “A” is for the AWSC and 
column “B” is for the California Bicycle warrant. 

Table 11 Bicycle Data Requirements 

Data Item 
Warrant 

1 2 3 4 5 6 7 8 9 A B 
Bicycle Data                     R 
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Chapter 5 – Warrants Tabs 
This chapter details the warrant specific tabs. All data can be entered in the Summary tab. 
However, warrant-specific data can be entered on the appropriate tab for Warrants 1 
through 9 (1 through 8 if using 2003 Federal Warrants), AWSC, and Bicycle (if the California 
option is selected).  

Traffic Volumes Used for Warrants 
Vehicular Volumes are used by Warrants 1, 2, 3, 7, 8 and 9. The user has the option to 
compare main street volumes to side street volumes. There is also an option to compare left 
turn volumes which will differ depending on the selection of the Federal or California 
MUTCD warrant. From the Federal MUTCD: 

“Option: At an intersection with a high volume of left-turn traffic from the major street, the 
signal warrant analysis may be performed in a manner that considers the higher of the 
major-street left-turn volumes as the “minor-street” volume and the corresponding single 
direction of opposing traffic on the major street as the “major-street” volume.” 

For Warrants 1, 2, 3, 7 and 8, the user may select the “Use Left Volume” check-box to 
compare the option above.  
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If the “Use Left Volume” is selected and the California 2012 option is selected, the volumes 
are compared differently. Refer to the following for differences on how volumes are used 
for the Federal and California warrants. 

 

Federal Warrant
Traditional Method

6

Check Major Street Lefts

California Warrant
Traditional Method (same as federal warrant)

Check Major Street Lefts

1F

2F

1C

2C

12 11 10

6
5
4

1
2 7 8 9

3

Major Street Volume 1+2+3+4+5+6 User may exclude any 
movement(s)

Minor Street Volume Max of 7+8+9
or 10+11+12

User may exclude any 
movement(s)

Major Street Volume If 4>1, 1+2+3
If 1>4, 4+5+6

User may exclude any 
movement(s)

Minor Street Volume Max 4 or 1 User may exclude any 
movement(s)

Major Street Volume 1+2+3+4+5+6 User may exclude any 
movement(s)

Minor Street Volume Max of 7+8+9
or 10+11+12

User may exclude any 
movement(s)

Major Street Volume If 4>1, 1+2+3+5+6
If 1>4, 2+3+4+5+6

User may exclude any 
movement(s)

Minor Street Volume If 4>1, 4+Max of 7+8+9 or 10+11+12
If 1>4, 1+Max of 7+8+9 or 10+11+12

User may exclude any 
movement(s)

Major 
Street
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Warrant 1: Eight-Hour Vehicular Volume 
Figure 13 illustrates the Warrant 1 data tab. 

 
Figure 13 Warrant 1 Tab 
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The Warrant 1 tab is the Eight Hour Vehicular Volume warrant. At least eight (8) hours must 
meet the requirements for condition A or condition B.  

There is also a combination of warrants test. For this test, the volumes used for the first part 
are reduced by 20% (uses 80% of the volume). If eight hours are met for condition A and B, 
then the warrant is met. 

This tab will indicate if Warrant Condition A or B has been met. If the warrant is met, the 
text will be shown in green. If the warrant is not met, the text will appear in red.  

Whether the condition is met or not, the number of hours actually met will be listed.  

Hours do not need to be on the hour. For instance, one hour could be from 7:15 a.m. to 8:15 
a.m. However, hours are not allowed to overlap. That is, if one hour is 7:15 to 8:15 a.m., then 
the next hour used cannot start before 8:30 a.m.  

The following data items are included on the Warrant 1 tab: 

Warrant 1 Information from MUTCD 
Support: 

The Minimum Vehicular Volume, Condition A, is intended for application at locations where 
a large volume of intersecting traffic is the principal reason to consider installing a traffic 
control signal. The Interruption of Continuous Traffic, Condition B, is intended for 
application at locations where Condition A is not satisfied and where the traffic volume on 
a major street is so heavy that traffic on a minor intersecting street suffers excessive delay 
or conflict in entering or crossing the major street. It is intended that Warrant 1 be treated 
as a single warrant. If Condition A is satisfied, then the criteria for Warrant 1 is satisfied and 
Condition B and the combination of Conditions A and B are not needed. Similarly, if 
Condition B is satisfied, then the criteria for Warrant 1 is satisfied and the combination of 
Conditions A and B is not needed. 

Standard: 

The need for a traffic control signal shall be considered if an engineering study finds that 
one of the following conditions exist for each of any 8 hours of an average day: 

A. The vehicles per hour given in both of the 100 percent columns of Condition A in Table 
4C-1 exist on the major-street and the higher-volume minor-street approaches, 
respectively, to the intersection; or 

B. The vehicles per hour given in both of the 100 percent columns of Condition B in Table 
4C-1 exist on the major-street and the higher-volume minor-street approaches, 
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respectively, to the intersection. In applying each condition the major-street and minor-
street volumes shall be for the same 8 hours. On the minor street, the higher volume shall 
not be required to be on the same approach during each of these 8 hours. 

Option: 

If the posted or statutory speed limit or the 85th-percentile speed on the major street 
exceeds 70 km/h or exceeds 40 mph, or if the intersection lies within the built-up area of an 
isolated community having a population of less than 10,000, the traffic volumes in the 70 
percent columns in Table 4C-1 may be used in place of the 100 percent columns. 

 
The combination of Conditions A and B is intended for application at locations where 
Condition A is not satisfied and Condition B is not satisfied and should be applied only after 
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an adequate trial of other alternatives that could cause less delay and inconvenience to 
traffic has failed to solve the traffic problems. 

Standard:  

The need for a traffic control signal shall be considered if an engineering study finds that 
both of the following conditions exist for each of any 8 hours of an average day: 

A. The vehicles per hour given in both of the 80 percent columns of Condition A in Table 4C-
1 exist on the major-street and the higher-volume minor-street approaches, respectively, to 
the intersection; and 

B. The vehicles per hour given in both of the 80 percent columns of Condition B in Table 4C-
1 exist on the major-street and the higher-volume minor-street approaches, respectively, to 
the intersection. 

These major-street and minor-street volumes shall be for the same 8 hours for each 
condition; however, the 8 hours satisfied in Condition A shall not be required to be the same 
8 hours satisfied in Condition B. On the minor street, the higher volume shall not be required 
to be on the same approach during each of the 8 hours. 

Option: 

If the posted or statutory speed limit or the 85th-percentile speed on the major street 
exceeds 70 km/h or exceeds 40 mph, or if the intersection lies within the built-up area of an 
isolated community having a population of less than 10,000, the traffic volumes in the 56 
percent columns in Table 4C-1 may be used in place of the 80 percent columns. 
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Warrant 2: Four-Hour Vehicular Volume 
Figure 14 illustrates the Warrant 2 data tab. 

 
Figure 14 Warrant 2 Tab 
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In this example, warrant data is plotted on Figure 4C-1 or 4C-2 from the MUTCD to see if the 
warrant is met. The plotted points represent the vehicles per hour on the major street (total 
of both approaches) and the corresponding vehicles per hour on the higher-volume minor-
street approach (one direction only).  

The MUTCD figure includes three (3) lines based on the given lane geometry. Based on the 
data entered, the warrant will be compared to the appropriate curve. The selected curve 
will be highlighted. When a plotted point meets the warrant, it will display as a green square. 
A point that is not met will be shown as a red triangle.  

The MUTCD warrants do not have a specific equation to determine the curves. However, the 
following equations have been used for the determination of the curves in Warrants 2. 

 

 
When any plotted point is within 5 vehicles from the curve, this point will be flagged. The 
curves in the program are based on a mathematical representation of the MUTCD curves. 
The mathematical curves do not always accurately predict the curve from the MUTCD and 
user discretion is advised when within the 5-vehicle threshold.  

Sometimes the data point will fall off of the graph. When the X coordinate is greater than the 
maximum value listed, the point will be shown on the edge of the graph.  
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Warrant 2 Information from MUTCD 
Support: 

The Four-Hour Vehicular Volume signal warrant conditions are intended to be applied 
where the volume of intersecting traffic is the principal reason to consider installing a traffic 
control signal. 

Standard: 

The need for a traffic control signal shall be considered if an engineering study finds that, 
for each of any 4 hours of an average day, the plotted points representing the vehicles per 
hour on the major street (total of both approaches) and the corresponding vehicles per hour 
on the higher-volume minor-street approach (one direction only) all fall above the 
applicable curve in Figure 4C-1 for the existing combination of approach lanes. On the minor 
street, the higher volume shall not be required to be on the same approach during each of 
these 4 hours. 

Option: 

If the posted or statutory speed limit or the 85th-percentile speed on the major street 
exceeds 70 km/h or exceeds 40 mph or if the intersection lies within the built-up area of an 
isolated community having a population of less than 10,000, Figure 4C-2 may be used in 
place of Figure 4C-1. 
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Warrant 3: Peak Hour 
Figure 15 illustrates the Warrant 3 data tab. 

 
Figure 15 Warrant 3 Tab 
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In this warrant data is plotted on Figure 4C-3 or 4C-4 from the MUTCD to see if the warrant 
is met. The plotted points represent the vehicles per hour on the major street (total of both 
approaches) and the corresponding vehicles per hour on the higher-volume minor-street 
approach (one direction only).  

The MUTCD figure includes three (3) lines based on the given lane geometry. Based on the 
data entered, the warrant will be compared to the appropriate curve. The selected curve 
will be highlighted. When a plotted point meets the warrant, it will display as a green square. 
A point that is not met will be shown as a red triangle.  

The MUTCD warrants do not have a specific equation to determine the curves. However, the 
following equations have been used for the determination of the curves in Warrants 3. 

 

 
When any plotted point is within 5 vehicles from the curve, this point will be flagged. The 
curves in the program are based on a mathematical representation of the MUTCD curves. 
The mathematical curves do not always accurately predict the curve from the MUTCD and 
user discretion is advised when within the 5-vehicle threshold.  

Sometimes the data point will fall off of the graph. When the X coordinate is greater than the 
maximum value listed, the point will be shown on the edge of the graph.  

The following data items are included on the Warrant 3 tab: 
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Warrant 3 Information from MUTCD 
Support: 

The Peak Hour signal warrant is intended for use at a location where traffic conditions are 
such that for a minimum of 1 hour of an average day, the minor-street traffic suffers undue 
delay when entering or crossing the major street. 

Standard: 

This signal warrant shall be applied only in unusual cases, such as office complexes, 
manufacturing plants, industrial complexes, or high-occupancy vehicle facilities that attract 
or discharge large numbers of vehicles over a short time. The need for a traffic control signal 
shall be considered if an engineering study finds that the criteria in either of the following 
two categories are met: 

A. If all three of the following conditions exist for the same 1 hour (any four consecutive 15-
minute periods) of an average day: 

1. The total stopped time delay experienced by the traffic on one minor-street approach (one 
direction only) controlled by a STOP sign equals or exceeds: 4 vehicle-hours for a one-lane 
approach; or 5 vehicle-hours for a two-lane approach, and 

2. The volume on the same minor-street approach (one direction only) equals or exceeds 
100 vehicles per hour for one moving lane of traffic or 150 vehicles per hour for two moving 
lanes, and 

3. The total entering volume serviced during the hour equals or exceeds 650 vehicles per 
hour for intersections with three approaches or 800 vehicles per hour for intersections with 
four or more approaches. 

B. The plotted point representing the vehicles per hour on the major street (total of both 
approaches) and the corresponding vehicles per hour on the higher-volume minor-street 
approach (one direction only) for 1 hour (any four consecutive 15-minute periods) of an 
average day falls above the applicable curve in Figure 4C-3 for the existing combination of 
approach lanes. 

Option: 

If the posted or statutory speed limit or the 85th-percentile speed on the major street 
exceeds 70 km/h or exceeds 40 mph, or if the intersection lies within the built-up area of an 
isolated community having a population of less than 10,000, Figure 4C-4 may be used in 
place of Figure 4C-3 to satisfy the criteria in the second category of the Standard. 
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Warrant 4: Pedestrian Volume (2003 Federal) 
Figure 16 illustrates the Warrant 4 data tab. 

 
Figure 16 Warrant 4 Tab (2003 Federal) 
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This is the Pedestrian Volume warrant. Two conditions are required to be considered met.  

Pedestrian volumes are treated similar to traffic volumes. Four (4) hours of 100 peds or 
more are required. Hours will not overlap. The warrant can also have 190 peds for 1 or more 
hours to meet the first part of the condition. 

The following additional data items are included on the Warrant 4 tab: 

New Signal will Restrict Flow of Traffic is a check if the new signal will restrict the flow 
of traffic. 

Pedestrian Crossing Speed is the walking speed of pedestrians (ft/sec).  

Adjacent Coordinated Signal and Adjacent Distance is used to determine the presence 
and distance of adjacent signals. The signal warrant should not be applied where the 
resultant spacing of traffic control signals would be less than 300 ft (90 m). 

Median Refuge is a divided street having a median of sufficient width for pedestrians to 
wait. 

Pedestrian Volumes are the normal pedestrian volumes crossing the roadway. 

Gaps in the traffic stream of adequate length to allow pedestrians to cross during the same 
period when the pedestrian volume criterion is satisfied.  Where there is a divided street 
having a median of sufficient width for pedestrians to wait, the requirement applies 
separately to each direction of vehicular traffic. 

Warrant 4 Information from 2003 MUTCD 
Support: 

The Pedestrian Volume signal warrant is intended for application where the traffic volume 
on a major street is so heavy that pedestrians experience excessive delay in crossing the 
major street. 

Standard: 

The need for a traffic control signal at an intersection or midblock crossing shall be 
considered if an engineering study finds that both of the following criteria are met: 

A. The pedestrian volume crossing the major street at an intersection or midblock location 
during an average day is 100 or more for each of any 4 hours or 190 or more during any 1 
hour; and 
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B. There are fewer than 60 gaps per hour in the traffic stream of adequate length to allow 
pedestrians to cross during the same period when the pedestrian volume criterion is 
satisfied.  

Where there is a divided street having a median of sufficient width for pedestrians to wait, 
the requirement applies separately to each direction of vehicular traffic. The Pedestrian 
Volume signal warrant shall not be applied at locations where the distance to the nearest 
traffic control signal along the major street is less than 90 m (300 ft), unless the proposed 
traffic control signal will not restrict the progressive movement of traffic. If this warrant is 
met and a traffic control signal is justified by an engineering study, the traffic control signal 
shall be equipped with pedestrian signal heads conforming to requirements set forth in 
Chapter 4E. 

Guidance: 

If this warrant is met and a traffic control signal is justified by an engineering study, then: 

A. If at an intersection, the traffic control signal should be traffic-actuated and should include 
pedestrian detectors. 

B. If at a non-intersection crossing, the traffic control signal should be pedestrian-actuated, 
parking and other sight obstructions should be prohibited for at least 30 m (100 ft) in 
advance of and at least 6.1 m (20 ft) beyond the crosswalk, and the installation should 
include suitable standard signs and pavement markings. C. Furthermore, if installed within 
a signal system, the traffic control signal should be coordinated. 

Option: 

The criterion for the pedestrian volume crossing the major roadway may be reduced as 
much as 50 percent if the average crossing speed of pedestrians is less than 1.2 m/sec (4 
ft/sec). A traffic control signal may not be needed at the study location if adjacent 
coordinated traffic control signals consistently provide gaps of adequate length for 
pedestrians to cross the street, even if the rate of gap occurrence is less than one per minute. 

Warrant 4: Pedestrian Volume (2009 Federal) 
The 2009 Federal MUTCD includes a significant change in Warrant 4, the Pedestrian Volume 
Warrant and is based on an extensive NCHRP research study. The 2003 Warrant required 
that two criteria be met in order to satisfy Warrant 4.  The 2009 Warrant includes two new 
criteria that are based on a combination of vehicular and pedestrian volumes for either 4-
hours or a single peak hour, and only one of the criteria needs to be met.   
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Figure 17 Warrant 4 Tab (2009 Federal) 
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Warrant 4 Information from 2009 MUTCD 
Support: 

The Pedestrian Volume signal warrant is intended for application where the traffic volume 
on a major street is so heavy that pedestrians experience excessive delay in crossing the 
major street. 

Standard: 

The need for a traffic control signal at an intersection or midblock crossing shall be 
considered if an engineering study finds that one of the following criteria is met: 

A. For each of any 4 hours of an average day, the plotted points representing the vehicles 
per hour on the major street (total of both approaches) and the corresponding pedestrians 
per hour crossing the major street (total of all crossings) all fall above the curve in Figure 
4C-5; or 

B. For 1 hour (any four consecutive 15-minute periods) of an average day, the plotted point 
representing the vehicles per hour on the major street (total of both approaches) and the 
corresponding pedestrians per hour crossing the major street (total of all crossings) falls 
above the curve in Figure 4C-7. 

Option: 

If the posted or statutory speed limit or the 85th-percentile speed on the major street 
exceeds 35 mph, or if the intersection lies within the built-up area of an isolated community 
having a population of less than 10,000, Figure 4C-6 may be used in place of Figure 4C-5 to 
evaluate Criterion A in Paragraph 2, and Figure 4C-8 may be used in place of Figure 4C-7 to 
evaluate Criterion B in Paragraph 2. 

Standard: 

The Pedestrian Volume signal warrant shall not be applied at locations where the distance 
to the nearest traffic control signal or STOP sign controlling the street that pedestrians 
desire to cross is less than 300 feet, unless the proposed traffic control signal will not restrict 
the progressive movement of traffic. 

If this warrant is met and a traffic control signal is justified by an engineering study, the 
traffic control signal shall be equipped with pedestrian signal heads complying with the 
provisions set forth in Chapter 4E. 

Guidance: 

If this warrant is met and a traffic control signal is justified by an engineering study, then: 
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A. If it is installed at an intersection or major driveway location, the traffic control signal 
should also control the minor-street or driveway traffic, should be traffic-actuated, and 
should include pedestrian detection. 

B. If it is installed at a non-intersection crossing, the traffic control signal should be installed 
at least 100 feet from side streets or driveways that are controlled by STOP or YIELD signs, 
and should be pedestrian-actuated. If the traffic control signal is installed at a non-
intersection crossing, at least one of the signal faces should be over the traveled way for 
each approach, parking and other sight obstructions should be prohibited for at least 100 
feet in advance of and at least 20 feet beyond the crosswalk or site accommodations should 
be made through curb extensions or other techniques to provide adequate sight distance, 
and the installation should include suitable standard signs and pavement markings. 

C. Furthermore, if it is installed within a signal system, the traffic control signal should be 
coordinated. 

Option: 

The criterion for the pedestrian volume crossing the major street may be reduced as much 
as 50 percent if the 15th-percentile crossing speed of pedestrians is less than 3.5 feet per 
second. 

08 A traffic control signal may not be needed at the study location if adjacent coordinated 
traffic control signals consistently provide gaps of adequate length for pedestrians to cross 
the street. 
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Warrant 5: School Crossing 
Figure 18 illustrates the Warrant 5 data tab. 

 
Figure 18 Warrant 5 Tab 

This Warrant is to be applied where school children cross a major street. 

The following additional data items are included on the Warrant 5 tab: 

Student Crossing Time Interval is the time interval (in minutes) that students are present. 

Student Pedestrians During Crossing Interval is the number of students crossing during 
the defined time period. 

New Signal will Restrict Flow of Traffic is checked if the new signal will restrict the flow 
of traffic. 

Acceptable Gaps During Student Crossing Interval is the number of gaps acceptable for 
a students to cross by direction.  

Adjacent Coordinated Signal and Adjacent Distance is used to determine the presence 
and distance of adjacent signals. The signal warrant should not be applied where the 
resultant spacing of traffic control signals would be less than 300 ft (90 m). 
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Warrant 5 Information from MUTCD 
Support: 

The School Crossing signal warrant is intended for application where the fact that school 
children cross the major street is the principal reason to consider installing a traffic control 
signal. 

Standard: 

The need for a traffic control signal shall be considered when an engineering study of the 
frequency and adequacy of gaps in the vehicular traffic stream as related to the number and 
size of groups of school children at an established school crossing across the major street 
shows that the number of adequate gaps in the traffic stream during the period when the 
children are using the crossing is less than the number of minutes in the same period (see 
Section 7A.03) and there are a minimum of 20 students during the highest crossing hour. 
Before a decision is made to install a traffic control signal, consideration shall be given to 
the implementation of other remedial measures, such as warning signs and flashers, school 
speed zones, school crossing guards, or a grade-separated crossing. The School Crossing 
signal warrant shall not be applied at locations where the distance to the nearest traffic 
control signal along the major street is less than 90 m (300 ft), unless the proposed traffic 
control signal will not restrict the progressive movement of traffic. 

Guidance: 

If this warrant is met and a traffic control signal is justified by an engineering study, then: 

A. If at an intersection, the traffic control signal should be traffic-actuated and should include 
pedestrian detectors. 

B. If at a nonintersection crossing, the traffic control signal should be pedestrian-actuated, 
parking and other sight obstructions should be prohibited for at least 30 m (100 ft) in 
advance of and at least 6.1 m (20 ft) beyond the crosswalk, and the installation should 
include suitable standard signs and pavement markings. 

C. Furthermore, if installed within a signal system, the traffic control signal should be 
coordinated. 
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Warrant 6: Coordinated Signal System 
Figure 19 illustrates the Warrant 6 data tab. 

 
Figure 19 Warrant 6 Tab 

This is the data tab for the coordinated signal system warrant.  

The following additional data items are included on the Warrant 6 tab: 

Acceptable Platooning indicates whether the adjacent traffic control signals provide the 
necessary degree of vehicular platooning. 

Adjacent Coordinated Signal and Adjacent Distance is used to determine the presence 
and distance of adjacent signals. The signal warrant should not be applied where the 
resultant spacing of traffic control signals would be less than 1000 ft (300 m). 

Warrant 6 Information from MUTCD 
Support: 

Progressive movement in a coordinated signal system sometimes necessitates installing 
traffic control signals at intersections where they would not otherwise be needed in order 
to maintain proper platooning of vehicles. 
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Standard: 

The need for a traffic control signal shall be considered if an engineering study finds that 
one of the following criteria is met: 

A. On a one-way street or a street that has traffic predominantly in one direction, the 
adjacent traffic control signals are so far apart that they do not provide the necessary degree 
of vehicular platooning. 

B. On a two-way street, adjacent traffic control signals do not provide the necessary degree 
of platooning and the proposed and adjacent traffic control signals will collectively provide 
a progressive operation. 

Guidance: 

The Coordinated Signal System signal warrant should not be applied where the resultant 
spacing of traffic control signals would be less than 300 m (1,000 ft). 
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Warrant 7: Crash Experience 
Figure 20 illustrates the Warrant 7 data tab. 

 
Figure 20 Warrant 7 Tab 
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This is the Crash Experience warrant.  

The following additional data items are included on the Warrant 7 tab: 

Community Size determines which MUTCD tables and figures are to be used.  Lower 
thresholds are required when the intersection is in an isolated community of less than 
10,000 people.  

Crashes Correctable by Signal is compared to the five crashes required in the Crash 
Experience warrant, but only those crashes susceptible to correction by signal installation. 

Alternatives Failed to Reduce Crash Frequency indicates if a trial of alternatives with 
satisfactory observance and enforcement has failed to reduce the crash frequency.  

Speed Limit and 85th Percentile Speed determine which MUTCD tables and figures are to 
be used.  Lower thresholds are required when the major street speed is above 40 mph (70 
km/h). 

Pedestrian Volumes are the normal pedestrian volumes crossing the roadway. 

Vehicle Volumes are used to determine the hourly volumes required by the warrant. 

Warrant 7 Information from MUTCD 
Support: 

The Crash Experience signal warrant conditions are intended for application where the 
severity and frequency of crashes are the principal reasons to consider installing a traffic 
control signal. 

Standard: 

The need for a traffic control signal shall be considered if an engineering study finds that all 
of the following criteria are met: 

A. Adequate trial of alternatives with satisfactory observance and enforcement has failed to 
reduce the crash frequency; and 

B. Five or more reported crashes, of types susceptible to correction by a traffic control 
signal, have occurred within a 12-month period, each crash involving personal injury or 
property damage apparently exceeding the applicable requirements for a reportable crash; 
and 

C. For each of any 8 hours of an average day, the vehicles per hour (vph) given in both of the 
80 percent columns of Condition A in Table 4C-1 (see Section 4C.02), or the vph in both of 
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the 80 percent columns of Condition B in Table 4C-1 exists on the major-street and the 
higher-volume minor-street approach, respectively, to the intersection, or the volume of 
pedestrian traffic is not less than 80 percent of the requirements specified in the Pedestrian 
Volume warrant. These major-street and minor-street volumes shall be for the same 8 
hours. On the minor street, the higher volume shall not be required to be on the same 
approach during each of the 8 hours. 

Option: 

If the posted or statutory speed limit or the 85th-percentile speed on the major street 
exceeds 70 km/h or exceeds 40 mph, or if the intersection lies within the built-up area of an 
isolated community having a population of less than 10,000, the traffic volumes in the 56 
percent columns in Table 4C-1 may be used in place of the 80 percent columns. 
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Warrant 8: Roadway Network 
Figure 21 illustrates the Warrant 8 data tab. 

 
Figure 21 Warrant 8 Tab 
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This is the Roadway Network warrant. This warrant utilizes Warrants 1, 2 and 3.  

The following data items are included on the Warrant 8 tab: 

Community Size determines which MUTCD tables and figures are to be used.  Lower 
thresholds are required when the intersection is in an isolated community of less than 
10,000 people.  

Total Entering Volume Growth Percentage is the yearly growth rate. 

Projected Time Period is used to project the Growth Percentage by this number of years 
into the future.  

Speed Limit and 85th Percentile determine which MUTCD tables and figures are to be 
used.  Lower thresholds are required when the major street speed is above 40 mph (70 
km/h)  

Vehicle Volumes are used to determine the hourly volumes required by the warrant.  

Delay Data is the average stopped delay for each approach is coded in minutes per vehicle.  
The appropriate volumes will be used to calculate the total stopped delay in vehicle-hours.   

Warrant 8 Information from MUTCD 
Support: 

Installing a traffic control signal at some intersections might be justified to encourage 
concentration and organization of traffic flow on a roadway network. 

Standard: 

The need for a traffic control signal shall be considered if an engineering study finds that the 
common intersection of two or more major routes meets one or both of the following 
criteria: 

A. The intersection has a total existing, or immediately projected, entering volume of at least 
1,000 vehicles per hour during the peak hour of a typical weekday and has 5-year projected 
traffic volumes, based on an engineering study, that meet one or more of Warrants 1, 2, and 
3 during an average weekday; or 

B. The intersection has a total existing or immediately projected entering volume of at least 
1,000 vehicles per hour for each of any 5 hours of a non-normal business day (Saturday or 
Sunday).  
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A major route as used in this signal warrant shall have one or more of the following 
characteristics: 

A. It is part of the street or highway system that serves as the principal roadway network 
for through traffic flow; or 

B. It includes rural or suburban highways outside, entering, or traversing a City; or 

C. It appears as a major route on an official plan, such as a major street plan in an urban area 
traffic and transportation study. 

Warrant 9: Intersection Near a Grade Crossing 
This is a new warrant within the 2009 Federal MUTCD for Intersections near a Highway-
Rail Grade Crossing. This warrant is for use at locations where the proximity of the 
intersection to a highway-rail grade crossing is the principal reason to consider installing a 
traffic control signal, and other warrants are not met.   
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Figure 22 2009 Federal Warrant 9 
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Warrant 9 Information from 2009 MUTCD 
Support: 

The Intersection Near a Grade Crossing signal warrant is intended for use at a location 
where none of the conditions described in the other eight traffic signal warrants are met, 
but the proximity to the intersection of a grade crossing on an intersection approach 
controlled by a STOP or YIELD sign is the principal reason to consider installing a traffic 
control signal. 

Guidance: 

This signal warrant should be applied only after adequate consideration has been given to 
other alternatives or after a trial of an alternative has failed to alleviate the safety concerns 
associated with the grade crossing. 

Among the alternatives that should be considered or tried are: 

A. Providing additional pavement that would enable vehicles to clear the track or that would 
provide space for an evasive maneuver, or 

B. Reassigning the stop controls at the intersection to make the approach across the track a 
non-stopping approach. 

Standard: 

The need for a traffic control signal shall be considered if an engineering study finds that 
both of the following criteria are met: 

A. A grade crossing exists on an approach controlled by a STOP or YIELD sign and the center 
of the track nearest to the intersection is within 140 feet of the stop line or yield line on the 
approach; and 

B. During the highest traffic volume hour during which rail traffic uses the crossing, the 
plotted point representing the vehicles per hour on the major street (total of both 
approaches) and the corresponding vehicles per hour on the minor-street approach that 
crosses the track (one direction only, approaching the intersection) falls above the 
applicable curve in Figure 4C-9 or 4C-10 for the existing combination of approach lanes over 
the track and the distance D, which is the clear storage distance as defined in Section 1A.13. 
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Guidance: 

The following considerations apply when plotting the traffic volume data on Figure 4C-9 or 
4C-10: 

A. Figure 4C-9 should be used if there is only one lane approaching the intersection at the 
track crossing location and Figure 4C-10 should be used if there are two or more lanes 
approaching the intersection at the track crossing location. 

B. After determining the actual distance D, the curve for the distance D that is nearest to the 
actual distance D should be used. For example, if the actual distance D is 95 feet, the plotted 
point should be compared to the curve for D = 90 feet. 

C. If the rail traffic arrival times are unknown, the highest traffic volume hour of the day 
should be used. 

Option: 

The minor-street approach volume may be multiplied by up to three adjustment factors as 
provided in Paragraphs 6 through 8. 

Because the curves are based on an average of four occurrences of rail traffic per day, the 
vehicles per hour on the minor-street approach may be multiplied by the adjustment factor 
shown in Table 4C-2 for the appropriate number of occurrences of rail traffic per day. 

Because the curves are based on typical vehicle occupancy, if at least 2% of the vehicles 
crossing the track are buses carrying at least 20 people, the vehicles per hour on the minor-
street approach may be multiplied by the adjustment factor shown in Table 4C-3 for the 
appropriate percentage of high-occupancy buses. 

Because the curves are based on tractor-trailer trucks comprising 10% of the vehicles 
crossing the track, the vehicles per hour on the minor-street approach may be multiplied by 
the adjustment factor shown in Table 4C-4 for the appropriate distance and percentage of 
tractor-trailer trucks. 

Standard: 

If this warrant is met and a traffic control signal at the intersection is justified by an 
engineering study, then: 

A. The traffic control signal shall have actuation on the minor street; 

B. Preemption control shall be provided in accordance with Sections 4D.27, 8C.09, and 
8C.10; and 
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C. The grade crossing shall have flashing-light signals (see Chapter 8C). 

Guidance: 

If this warrant is met and a traffic control signal at the intersection is justified by an 
engineering study, the grade crossing should have automatic gates (see Chapter 8C). 
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All-Way Stop Control (AWSC) Warrant 
Figure 23 illustrates the AWSC data tab. 

 
Figure 23 AWSC Tab 
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This is the All-Way Stop Control (AWSC) warrant.   

AWSC Information from MUTCD 
Support: 

Multiway stop control can be useful as a safety measure at intersections if certain traffic 
conditions exist. Safety concerns associated with multiway stops include pedestrians, 
bicyclists, and all road users expecting other road users to stop. Multiway stop control is 
used where the volume of traffic on the intersecting roads is approximately equal. 

The restrictions on the use of STOP signs described in Section 2B.05 also apply to multiway 
stop applications. 

Guidance: 

The decision to install multiway stop control should be based on an engineering study. 

The following criteria should be considered in the engineering study for a multiway STOP 
sign installation: 

A.  Where traffic control signals are justified, the multiway stop is an interim measure that 
can be installed quickly to control traffic while arrangements are being made for the 
installation of the traffic control signal. 

B.  A crash problem, as indicated by 5 or more reported crashes in a 12-month period that 
are susceptible to correction by a multiway stop installation. Such crashes include 
right- and left-turn collisions as well as right-angle collisions. 

C.  Minimum volumes: 

1.  The vehicular volume entering the intersection from the major street approaches 
(total of both approaches) averages at least 300 vehicles per hour for any 8 hours 
of an average day, and 

2.  The combined vehicular, pedestrian, and bicycle volume entering the 
intersection from the minor street approaches (total of both approaches) 
averages at least 200 units per hour for the same 8 hours, with an average delay 
to minor-street vehicular traffic of at least 30 seconds per vehicle during the 
highest hour, but 

3.  If the 85th-percentile approach speed of the major-street traffic exceeds 65 km/h 
or exceeds 40 mph, the minimum vehicular volume warrants are 70 percent of 
the above values. 
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D.  Where no single criterion is satisfied, but where Criteria B, C.1, and C.2 are all satisfied 
to 80 percent of the minimum values. Criterion C.3 is excluded from this condition. 

Option: 

 Other criteria that may be considered in an engineering study include: 

A.  The need to control left-turn conflicts; 

B.  The need to control vehicle/pedestrian conflicts near locations that generate high 
pedestrian volumes; 

C.  Locations where a road user, after stopping, cannot see conflicting traffic and is not 
able to reasonably safely negotiate the intersection unless conflicting cross traffic is 
also required to stop; and 

D.  An intersection of two residential neighborhood collector (through) streets of similar 
design and operating characteristics where multiway stop control would improve 
traffic operational characteristics of the intersection. 
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Bicycle Warrant 
Figure 24 illustrates the Bicycle data tab. This tab is only available when you select the 
California 2012 Option from the toolbar. 

 
Figure 24 Bicycle Tab 
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The following data items are included on the Bicycle tab: 

Bicycle Warrant Information from California MUTCD 
Section 4C.102(CA) Bicycle Signal Warrant  

Guidance:  

A bicycle signal should be considered for use only when the volume and collision or volume 
and geometric warrants have been met:  

1.  Volume; When W = B x V and W > 50,000 and B > 50.  

Where: W is the volume warrant. B is the number of bicycles at the peak hour entering 
the intersection. V is the number of vehicles at the peak hour entering the intersection. 
B and V shall use the same peak hour.  

2.  Collision; When 2 or more bicycle/vehicle collisions of types susceptible to correction 
by a bicycle signal have occurred over a 12-month period and the responsible public 
works official determines that a bicycle signal will reduce the number of collisions.  

3.  Geometric; (a) Where a separate bicycle/ multi use path intersects a roadway. (b) At 
other locations to facilitate a bicycle movement that is not permitted for a motor vehicle.   
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Chapter 6 – Reports and Printing 
Single Intersection Reports 
To create a report of the active window for the selected intersection, select the File→Print 
command, select the Printer icon in the toolbar, or choose [Ctrl]+[P]. A preview of the report 
for the given tab will be shown. The selected report will show for all intersections in the 
Intersection List. See . 
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Figure 25 Single Intersection Report 
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To create all active reports for the slected intersection, selete the File→Print-All-Reports 
command or choose [Ctrl]+[R]. A preview of the report for the given tab will be shown. 

To change pages use the buttons [|<], [<], [>], and [>|]. You can also change pages using the 
page number of X box.  

To resize the preview, use the dropdown size. You can also choose to fit width or show the 
whole page. 

To print the report, select the Printer icon button from the Report Preview toolbar.   

Multiple Intersection Reports 
To create a report that includes multiple intersections, select the View→Multiple 
Intersection Reports menu item.  To choose intersections for a report, hold down the 
[CTRL] key and click on each desired intersection.  Next, select the report to generate using 
the Select Report listbox, then click Run Report. 
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Summary Matrix Report 
The summary matrix report shows the status of the eight warrants for the selected 
intersections. The result can show Met for a signal that meets the warrants; Not Met when 
the warrant is analyzed but not met; or N/A for a warrant that has not been analyzed. 

 

 

Summary Report 
The summary report shows a summary of the warrant status for the intersections selected. 
The top portion list the Street Name, Directions, Number of Lanes and Approach Speed. The 
lower portion shows the status of the warrant (No or Yes). 
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Raw Volumes and Weekend Volumes Report 
This report illustrates the raw volumes and weekend volumes entered on the Summary, 
Vehicle Volumes sub-tab. Refer to page 4-9 for full details. 

   

Pedestrian Volumes Report 
Select this report to print the Pedestrian Volumes entered on the Summary, Pedestrian 
Volumes sub-tab. Refer to page 4-11 for details on this report. 

Gaps Report 
This report shows the gap values for pedestrians used for pedestrian warrants. Refer to 
page 4-12 for details. 
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Delays Report 
Select this report to show the delay value inputs used for the warrant analysis. Refer to page 
4-14 for full delails. 

Site Information Report 
Select this report to detail the information input on the Summary, Site Information sub-tab. 
Refer to page 4-4 for details.  
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Warrant 1 – Eight-hour Vehicular Volume Report 
This report shows the status and details for Warrant 1. The report illustrates the status of 
the warrant for each 15-minute increment. Refer to page 5-3 for details on this warrant.  
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Warrant 2 – Four-hour Vehicular Volume Report 
This report shows the status and details for Warrant 2. The report illustrates the status of 
the warrant on the MUTCD warrant graph. Refer to page 5-7 for details on this warrant.  
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Warant 3 – Peak Hour Report 
This report shows the status and details for Warrant 3. The report illustrates the status of 
the warrant on the MUTCD warrant graph. Refer to page 5-11 for details on this warrant.  
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Warrant 4 – Pedestrian Volume Report (2003 MUTCD) 
This report shows the status and details for Warrant 4 using the 2003 MUTCD methods. The 
report illustrates the status of the warrant for each 15-minute increment. Refer to page 5-
15 for details on this warrant.  
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Warrant 4 – Pedestrian Volume Report (2009 MUTCD) 
This report shows the status of the details for Warrant 4 using the 2009 MUTCD methods. 
Refer to page 5-17 for details on this warrant. 
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Warrant 5 – School Crossing 
This report shows the status and details for Warrant 5. Refer to page 5-22 for details on this 
warrant.  
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Warrant 6 – Coordinated Signal System 
This report shows the status and details for Warrant 6. Refer to page 5-24 for details on this 
warrant.  
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Warrant 7 – Crash Experience Report 
This report shows the status and details for Warrant 7. Refer to page 5-26 for details on this 
warrant.  
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Warrant 8 – Roadway Network Report 
This report shows the status and details for Warrant 8. Refer to page 5-29 for details on this 
warrant.  
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Warrant 9 – Intersection Near a Grade Crossing 
This report shows the status and details for Warrant 9 (Federal 2009 report only). Refer to 
page 5-31 for details on this warrant.  
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AWSC Warrant Report 
This report shows the status and details for the AWSC Warrant. Refer to page 5-38 for 
details on this warrant.  
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Bicycle Warrant Report 
This report shows the status and details for the Bicycle Warrant. Refer to page 5-41 for 
details on this warrant. 





 7-1 

Chapter 7 – Database Access 
 
Universal Traffic Data Format (UTDF) is a standard specification for transferring data 
between various software packages. UTDF is useful for transferring data to and from 
Synchro and for reading volume data into Warrants. 

Import UTDF Data  
Warrants 10 can import a Synchro UTDF Layout, Volume and combined data files. To Import 
data, use the command Transfer→Import command. TMC style Volume files (TMC#.vol) files 
can also be imported.  

Import Layout Data 
The Layout UTDF file stores information about the location of intersections and how they 
connect to each other. This file includes coordinates for intersections and the node numbers 
of adjoining intersections. Warrants 10 will import the ID number, intersection names and 
intersection type. The Intersection type includes Signalized, Unsignalized, Roundabout, 
External and Bend.  

To create a Layout file from Synchro, refer to the Synchro User Guide. 

To import Layout data, do the following:  

• Create a new Warrants 10 file (File→New).  

• Select the menu command Transfer→Import→UTDF→Layout.  

• Choose Comma Delimited from the ‘File of Type’ dropdown  

• Select the file and press [Open].  

• The data from this UTDF Layout file will now be in your Warrants file.  

Import Volume Data 
The VOLUME file(s) stores turning movement counts. The volume file(s) stores the 
intersection number along with the date, and time of the volume data. Warrants 10 will 
import volume by ID number.  



7-2 

The Volume file should be in the Volume.csv format. The data must be in 15-minute format 
(not hourly volumes). To create a Volume file, refer to the Synchro User Guide. 

To import Volume data, do the following:  

• Open an existing Warrants file with the Intersection list and ID.   

• Select the menu command Transfer→Import→UTDF→Volume.  

• Choose Comma Delimited from the ‘File of Type’ dropdown  

• Select the file and press [Open].  

• The volume data for matching ID numbers will be imported into you Warrants file.  

Import/Export Combined Data Format 
Synchro 10 can create a combined data file format. This file contains the complete set of 
Synchro data including sections on Layout, Lanes, Volumes, Timings, Phasing, etc. Warrants 
can import data from the Layout and Lanes section. Volumes cannot be imported. Synchro 
stores volumes in hourly format, Warrants requires data in 15 minute increments. The 
Timing and Phasing data is not used by Warrants. To create a Combined data file, refer to 
the Synchro User Guide. 

To import a Combined Synchro data file, do the following:  

• Create a new Warrants 10 file (File→New).  

• Select the menu command Transfer→Import→UTDF→Combined File.  

• Choose Comma Delimited from the ‘File of Type’ dropdown  

• Select the file and press [Open].  

• The layout and applicable lanes data will be imported into your Warrants file.  

To export a Combined Synchro data file, do the following:  

• Open an existing Warrants file.   

• Select the menu command Transfer→Export →UTDF Combined File.  

• Choose Comma Delimited from the ‘File of Type’ dropdown  

• Select the file and press [Open].  

• Choose the Time Range for which to export volumes 
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• The layout and applicable lanes data will be exported to a combined data file 
format. 

Import TMC (*.VOL) Format 
TMC files are text files that store timing data from a single intersection from multiple time 
periods. The data is stored in a fixed length format with each line representing a single time 
period. Refer to the Synchro User Guide for full details on the TMC (*.vol) format. 

To import a TMC (*.vol) data file, do the following:  

• Open an existing Warrants file with the Intersection list and ID.   

• Select the menu command Transfer→Import→Vol Files.  

• Choose Vol Files from the ‘File of Type’ dropdown  

• Select the file and press [Open].  

• The volume data for matching ID numbers will be imported into your Warrants file.   
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